What’s Vulnerable › Vulnerabilities
CVE-2024-52532
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-11 · updated 2026-06-17
- Weakness: CWE-835
Description
GNOME libsoup before 3.6.1 has an infinite loop, and memory consumption. during the reading of certain patterns of WebSocket data from clients.
Affected products
- GNOME libsoup: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: GNOME libsoup 3.6.1. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/libsoup/-/issues/391
- https://gitlab.gnome.org/GNOME/libsoup/-/merge_requests/410
- https://gitlab.gnome.org/Teams/Releng/security/-/wikis/home
- https://lists.debian.org/debian-lts-announce/2024/12/msg00014.html
Get alerted when CVE-2024-52532 or the next vulnerability affects your stack