What’s Vulnerable › Vulnerabilities
CVE-2024-52533
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-11 · updated 2026-10-15
- Weakness: CWE-120
Description
gio/gsocks4aproxy.c in GNOME GLib before 2.82.1 has an off-by-one error and resultant buffer overflow because SOCKS4_CONN_MSG_LEN is not sufficient for a trailing '\0' character.
Affected products
- Debian Linux: 11.0
- GNOME GLib: before 2.82.1 — fixed in 2.82.1
- Active IQ Unified Manager for VMware vSphere, Linux, and Microsoft Windows: all versions
- NetApp Ontap Tools: 10
How to fix
Upgrade to a fixed version: GNOME GLib 2.82.1. Check the vendor advisory for mitigations.
References
- https://gitlab.gnome.org/GNOME/glib/-/issues/3461
- https://gitlab.gnome.org/GNOME/glib/-/releases/2.82.1
- https://gitlab.gnome.org/Teams/Releng/security/-/wikis/home
- http://www.openwall.com/lists/oss-security/2024/11/12/11
- https://lists.debian.org/debian-lts-announce/2024/11/msg00020.html
- https://security.netapp.com/advisory/ntap-20241206-0009/
- https://cert-portal.siemens.com/productcert/html/ssa-089022.html
- https://cert-portal.siemens.com/productcert/html/ssa-202008.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2024-52533 or the next vulnerability affects your stack