What’s Vulnerable › Vulnerabilities
CVE-2024-5257: Improper Access Control in GitLab
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-11 · updated 2026-06-17
- Weakness: CWE-284
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.0.4 and from 17.1 prior to 17.1.2 where a Developer user with `admin_compliance_framework` custom role may have been able to modify the URL for a group namespace.
Affected products
- GitLab: from 17.0.0 before 17.0.4; from 17.1.0 before 17.1.2 — fixed in 17.0.4, 17.1.2
How to fix
Upgrade to a fixed version: GitLab 17.0.4, 17.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/463149
- https://hackerone.com/reports/2513934
- https://gitlab.com/gitlab-org/gitlab/-/issues/463149
- https://hackerone.com/reports/2513934
Get alerted when CVE-2024-5257 or the next vulnerability affects your stack