What’s Vulnerable › Vulnerabilities
CVE-2024-5259: MultiVendorX Marketplace – WooCommerce MultiVendor Marketplace Solution <= 4.1.11 - Authenticated (Contributor+) Stored Cross-Site Scripting via hover_animation Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The MultiVendorX Marketplace – WooCommerce MultiVendor Marketplace Solution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘hover_animation’ parameter in all versions up to, and including, 4.1.11 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- MultiVendorX: before 4.1.12 — fixed in 4.1.12
How to fix
Upgrade to a fixed version: MultiVendorX 4.1.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/trunk/packages/mvx-elementor/widgets/class-mvx-widget-storesocial.php#L150
- https://plugins.trac.wordpress.org/changeset/3097002/
- https://wordpress.org/plugins/dc-woocommerce-multi-vendor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59a349f2-048d-49a5-92ea-c19f1d1cd45e?source=cve
- https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/trunk/packages/mvx-elementor/widgets/class-mvx-widget-storesocial.php#L150
- https://plugins.trac.wordpress.org/changeset/3097002/
- https://wordpress.org/plugins/dc-woocommerce-multi-vendor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/59a349f2-048d-49a5-92ea-c19f1d1cd45e?source=cve
Get alerted when CVE-2024-5259 or the next vulnerability affects your stack