What’s Vulnerable › Vulnerabilities

CVE-2024-52599: Tuleap vulnerable to XSS in the Gantt chart of the tracker plugin

Description

Tuleap is an open source suite to improve management of software developments and collaboration. In Tuleap Community Edition prior to version 16.1.99.50 and Tuleap Enterprise Edition prior to versions 16.1-4 and 16.0-7, a malicious user with the ability to create an artifact in a tracker with a Gantt chart could force a victim to execute uncontrolled code. Tuleap Community Edition 16.1.99.50, Tuleap Enterprise Edition 16.1-4, and Tuleap Enterprise Edition 16.0-7 contain a fix.

Affected products

How to fix

Upgrade to a fixed version: Enalean tuleap 16.0-7, 16.1-4, 16.1.99.50. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52599 or the next vulnerability affects your stack