What’s Vulnerable › Vulnerabilities
CVE-2024-5261: TLS certificate are not properly verified when utilizing LibreOfficeKit
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-25 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper Certificate Validation vulnerability in LibreOffice "LibreOfficeKit" mode disables TLS certification verification LibreOfficeKit can be used for accessing LibreOffice functionality through C/C++. Typically this is used by third party components to reuse LibreOffice as a library to convert, view or otherwise interact with documents. LibreOffice internally makes use of "curl" to fetch remote resources such as images hosted on webservers. In affected versions of LibreOffice, when used in LibreOfficeKit mode only, then curl's TLS certification verification was disabled (CURLOPT_SSL_VERIFYPEER of false) In the fixed versions curl operates in LibreOfficeKit mode the same as in standard mode with CURLOPT_SSL_VERIFYPEER of true. This issue affects LibreOffice before version 24.2.4.
Affected products
- The Document Foundation LibreOffice: before 24.2.4 — fixed in 24.2.4
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 24.2.4. Check the vendor advisory for mitigations.
References
- https://www.libreoffice.org/about-us/security/advisories/cve-2024-5261
- https://www.libreoffice.org/about-us/security/advisories/cve-2024-5261
Get alerted when CVE-2024-5261 or the next vulnerability affects your stack