What’s Vulnerable › Vulnerabilities
CVE-2024-52612: SolarWinds Platform Reflected Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-79
Description
SolarWinds Platform is vulnerable to a reflected cross-site scripting vulnerability. This was caused by an insufficient sanitation of input parameters. This vulnerability requires authentication by a high- privileged account to be exploitable.
Affected products
- SolarWinds Platform: before 2025.1 — fixed in 2025.1
How to fix
Upgrade to a fixed version: SolarWinds Platform 2025.1. Check the vendor advisory for mitigations.
References
- https://documentation.solarwinds.com/en/success_center/orionplatform/content/release_notes/solarwinds_platform_2025-1_release_notes.htm
- https://www.solarwinds.com/trust-center/security-advisories/cve-2024-52612
Get alerted when CVE-2024-52612 or the next vulnerability affects your stack