What’s Vulnerable › Vulnerabilities
CVE-2024-52794: Magnific lightbox susceptible to Cross-site Scripting in Discourse
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source platform for community discussion. Users clicking on the lightbox thumbnails could be affected. This problem is patched in the latest version of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- discourse: before 3.3.2; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3 — fixed in 3.3.2, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.2, 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52794 or the next vulnerability affects your stack