What’s Vulnerable › Vulnerabilities
CVE-2024-5280: WP Affiliate Platform < 6.5.1 - POST Reflected XSS
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The wp-affiliate-platform WordPress plugin before 6.5.1 does not have CSRF check in some places, and is missing sanitisation as well as escaping, which could allow attackers to make non-logged in users execute an XSS payload via a CSRF attack
Affected products
- wp-affiliate-platform: before 6.5.1 — fixed in 6.5.1
How to fix
Upgrade to a fixed version: wp-affiliate-platform 6.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bbc214ba-4e97-4b3a-a21b-2931a9e36973/
- https://wpscan.com/vulnerability/bbc214ba-4e97-4b3a-a21b-2931a9e36973/
Get alerted when CVE-2024-5280 or the next vulnerability affects your stack