What’s Vulnerable › Vulnerabilities
CVE-2024-52804: Tornado has HTTP cookie parsing DoS vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-400
Description
Tornado is a Python web framework and asynchronous networking library. The algorithm used for parsing HTTP cookies in Tornado versions prior to 6.4.2 sometimes has quadratic complexity, leading to excessive CPU consumption when parsing maliciously-crafted cookie headers. This parsing occurs in the event loop thread and may block the processing of other requests. Version 6.4.2 fixes the issue.
Affected products
- tornadoweb tornado: before 6.4.2 — fixed in 6.4.2
- Pypi Tornado: before 6.4.2; 0.2, 1.0, 1.1, 1.1.1, 1.2, 1.2.1 (+67) — fixed in 6.4.2
How to fix
Upgrade to a fixed version: tornadoweb tornado 6.4.2; Pypi Tornado 6.4.2. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-7pwv-g7hj-39pr
- https://github.com/tornadoweb/tornado/commit/d5ba4a1695fbf7c6a3e54313262639b198291533
- https://github.com/tornadoweb/tornado/security/advisories/GHSA-8w49-h785-mj3c
- https://lists.debian.org/debian-lts-announce/2025/01/msg00000.html
Get alerted when CVE-2024-52804 or the next vulnerability affects your stack