What’s Vulnerable › Vulnerabilities
CVE-2024-52805: Synapse allows unsupported content types to lead to memory exhaustion
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-03 · updated 2026-06-17
- Weakness: CWE-770
Description
Synapse is an open-source Matrix homeserver. In Synapse before 1.120.1, multipart/form-data requests can in certain configurations transiently increase memory consumption beyond expected levels while processing the request, which can be used to amplify denial of service attacks. Synapse 1.120.1 resolves the issue by denying requests with unsupported multipart/form-data content type.
Affected products
- matrix-org synapse: before 1.120.1 — fixed in 1.120.1
How to fix
Upgrade to a fixed version: matrix-org synapse 1.120.1. Check the vendor advisory for mitigations.
References
- https://github.com/element-hq/synapse/security/advisories/GHSA-rfq8-j7rh-8hf2
- https://github.com/twisted/twisted/issues/4688#issuecomment-1167705518
- https://github.com/twisted/twisted/issues/4688#issuecomment-2385711609
Get alerted when CVE-2024-52805 or the next vulnerability affects your stack