What’s Vulnerable › Vulnerabilities
CVE-2024-52810: Prototype Pollution in @intlify/shared >=9.7.0 <= 10.0.4
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-29 · updated 2026-06-17
- Weakness: CWE-1321
Description
@intlify/shared is a shared library for the intlify project. The latest version of @intlify/shared (10.0.4) is vulnerable to Prototype Pollution through the entry function(s) lib.deepCopy. An attacker can supply a payload with Object.prototype setter to introduce or modify properties within the global prototype chain, causing denial of service (DoS) as the minimum consequence. Moreover, the consequences of this vulnerability can escalate to other injection-based attacks, depending on how the library integrates within the application. For instance, if the polluted property propagates to sensitive Node.js APIs (e.g., exec, eval), it could enable an attacker to execute arbitrary commands within the application's context. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- intlify vue-i18n: through 9.7.0; before 9.14.2; through 10.0.0; before 10.0.5 — fixed in 10.0.5, 9.14.2
How to fix
Upgrade to a fixed version: intlify vue-i18n 10.0.5, 9.14.2. Check the vendor advisory for mitigations.
References
- https://github.com/intlify/vue-i18n/commit/9f20909ef8c9232a1072d7818e12ed6d6451024d
- https://github.com/intlify/vue-i18n/security/advisories/GHSA-hjwq-mjwj-4x6c
Get alerted when CVE-2024-52810 or the next vulnerability affects your stack