What’s Vulnerable › Vulnerabilities
CVE-2024-5283: WP Affiliate Platform < 6.5.1 - Reflected XSS via Lead Editing
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-affiliate-platform WordPress plugin before 6.5.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Affected products
- wp-affiliate-platform: before 6.5.1 — fixed in 6.5.1
How to fix
Upgrade to a fixed version: wp-affiliate-platform 6.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3e1adcd3-7c46-45e8-9e2b-2ede0d79c943/
- https://wpscan.com/vulnerability/3e1adcd3-7c46-45e8-9e2b-2ede0d79c943/
Get alerted when CVE-2024-5283 or the next vulnerability affects your stack