What’s Vulnerable › Vulnerabilities

CVE-2024-52844: Adobe Experience Manager | Cross-site Scripting (DOM-based XSS) (CWE-79)

Description

Adobe Experience Manager versions 6.5.21 and earlier are affected by a DOM-based Cross-Site Scripting (XSS) vulnerability that could be exploited by an attacker to execute arbitrary code in the context of the victim's browser session. By manipulating a DOM element through a crafted URL or user input, the attacker can inject malicious scripts that run when the page is rendered. This type of attack requires user interaction, as the victim would need to visit a malicious link or input data into a compromised form.

Affected products

How to fix

Upgrade to a fixed version: Adobe Experience Manager 2024.11.0, 6.5.22.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52844 or the next vulnerability affects your stack