What’s Vulnerable › Vulnerabilities
CVE-2024-5285: WP Affiliate Platform < 6.5.2 - Affiliate Deletion via CSRF
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-352
Description
The wp-affiliate-platform WordPress plugin before 6.5.2 does not have CSRF check in place when deleting affiliates, which could allow attackers to make a logged in user change delete them via a CSRF attack
Affected products
- wp-affiliate-platform: before 6.5.2 — fixed in 6.5.2
How to fix
Upgrade to a fixed version: wp-affiliate-platform 6.5.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/792f3904-88bd-47d1-9049-afccdd74853a/
- https://wpscan.com/vulnerability/792f3904-88bd-47d1-9049-afccdd74853a/
Get alerted when CVE-2024-5285 or the next vulnerability affects your stack