What’s Vulnerable › Vulnerabilities
CVE-2024-5287: WP Affiliate Platform < 6.5.1 - Profile Update via CSRF
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-352
Description
The wp-affiliate-platform WordPress plugin before 6.5.1 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in user change them via a CSRF attack
Affected products
- wp-affiliate-platform: before 6.5.1 — fixed in 6.5.1
How to fix
Upgrade to a fixed version: wp-affiliate-platform 6.5.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b4fd535c-a273-419d-9e2e-be1cbd822793/
- https://wpscan.com/vulnerability/b4fd535c-a273-419d-9e2e-be1cbd822793/
Get alerted when CVE-2024-5287 or the next vulnerability affects your stack