What’s Vulnerable › Vulnerabilities
CVE-2024-52871
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-17 · updated 2026-06-17
Description
In Flagsmith before 2.134.1, it is possible to bypass the ALLOW_REGISTRATION_WITHOUT_INVITE setting.
Affected products
- Flagsmith: before 2.134.1 — fixed in 2.134.1
How to fix
Upgrade to a fixed version: Flagsmith 2.134.1. Check the vendor advisory for mitigations.
References
- https://github.com/Flagsmith/flagsmith/compare/v2.134.0...v2.134.1
- https://github.com/Flagsmith/flagsmith/pull/4454
Get alerted when CVE-2024-52871 or the next vulnerability affects your stack