What’s Vulnerable › Vulnerabilities
CVE-2024-52897: IBM MQ information disclosure
- Severity: medium (CVSS 6.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-209
Description
IBM MQ 9.2 LTS, 9.3 LTS, 9.3 CD, 9.4 LTS, and 9.4 CD web console could allow a remote attacker to obtain sensitive information when a detailed technical error message is returned.
Affected products
- IBM MQ: from 9.2.0.0 before 9.2.0.30; from 9.3.0 before 9.4.1; from 9.3.0.0 before 9.3.0.26; from 9.4.0.0 before 9.4.0.7 — fixed in 9.2.0.30, 9.3.0.26, 9.4.0.7, 9.4.1
How to fix
Upgrade to a fixed version: IBM MQ 9.2.0.30, 9.3.0.26, 9.4.0.7, 9.4.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52897 or the next vulnerability affects your stack