What’s Vulnerable › Vulnerabilities

CVE-2024-52900: IBM Cognos Analytics cross-site scripting

Description

IBM Cognos Analytics 11.2.0 through 12.2.4 Fix Pack 5 and 12.0.0 through 12.0.4 is vulnerable to stored cross-site scripting. This vulnerability allows authenticated users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Affected products

How to fix

Upgrade to a fixed version: IBM Cognos Analytics 11.2.4, 12.0.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52900 or the next vulnerability affects your stack