What’s Vulnerable › Vulnerabilities
CVE-2024-52912
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-190
Description
Bitcoin Core before 0.21.0 allows a network split that is resultant from an integer overflow (calculating the time offset for newly connecting peers) and an abs64 logic bug.
Affected products
- Bitcoin Core: before 0.21.0 — fixed in 0.21.0
How to fix
Upgrade to a fixed version: Bitcoin Core 0.21.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/07/03/disclose-timestamp-overflow/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
Get alerted when CVE-2024-52912 or the next vulnerability affects your stack