What’s Vulnerable › Vulnerabilities
CVE-2024-52913
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-770
Description
In Bitcoin Core before 0.21.0, an attacker could prevent a node from seeing a specific unconfirmed transaction, because transaction re-requests are mishandled.
Affected products
- Bitcoin Core: before 0.21.0 — fixed in 0.21.0
How to fix
Upgrade to a fixed version: Bitcoin Core 0.21.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/07/03/disclose_already_asked_for/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
Get alerted when CVE-2024-52913 or the next vulnerability affects your stack