What’s Vulnerable › Vulnerabilities
CVE-2024-52915
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-770
Description
Bitcoin Core before 0.20.0 allows remote attackers to cause a denial of service (memory consumption) via a crafted INV message.
Affected products
- Bitcoin Core: before 0.20.0 — fixed in 0.20.0
How to fix
Upgrade to a fixed version: Bitcoin Core 0.20.0. Check the vendor advisory for mitigations.
References
- https://bitcoincore.org/en/2024/07/03/disclose-inv-buffer-blowup/
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
Get alerted when CVE-2024-52915 or the next vulnerability affects your stack