What’s Vulnerable › Vulnerabilities
CVE-2024-52946
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-276
Description
An issue was discovered in LemonLDAP::NG before 2.20.1. An Improper Check during session refresh allows an authenticated user to raise their authentication level if the admin configured an "Adaptative authentication rule" with an increment instead of an absolute value.
Affected products
- Lemonldap-Ng: before 2.20.1 — fixed in 2.20.1
How to fix
Upgrade to a fixed version: Lemonldap-Ng 2.20.1. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/3255
- https://lists.debian.org/debian-lts-announce/2024/11/msg00037.html
Get alerted when CVE-2024-52946 or the next vulnerability affects your stack