What’s Vulnerable › Vulnerabilities

CVE-2024-52965

Description

A missing critical step in authentication vulnerability [CWE-304] in Fortinet FortiOS version 7.6.0 through 7.6.1, 7.4.0 through 7.4.5, 7.2.0 through 7.2.10, and before 7.0.16 & FortiProxy version 7.6.0 through 7.6.1, 7.4.0 through 7.4.8, 7.2.0 through 7.2.13 and before 7.0.20 allows an API-user using api-key + PKI user certificate authentication to login even if the certificate is invalid.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.0.17, 7.2.11, 7.4.6; Fortinet FortiProxy 7.0.21, 7.2.14, 7.4.9, 7.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52965 or the next vulnerability affects your stack