What’s Vulnerable › Vulnerabilities
CVE-2024-52974
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue has been identified where a specially crafted request sent to an Observability API could cause the kibana server to crash. A successful attack requires a malicious user to have read permissions for Observability assigned to them.
Affected products
- Kibana: from 7.17.0 before 7.17.23; from 8.0.0 before 8.15.1 — fixed in 7.17.23, 8.15.1
How to fix
Upgrade to a fixed version: Kibana 7.17.23, 8.15.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52974 or the next vulnerability affects your stack