What’s Vulnerable › Vulnerabilities
CVE-2024-52975: Fleet Server sensitive information exposure via logs
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-23 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was identified in Fleet Server where Fleet policies that could contain sensitive information were logged on INFO and ERROR log levels. The nature of the sensitive information largely depends on the integrations enabled.
Affected products
- Elastic Fleet Server: from 8.13.0 before 8.15.0 — fixed in 8.15.0
How to fix
Upgrade to a fixed version: Elastic Fleet Server 8.15.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52975 or the next vulnerability affects your stack