What’s Vulnerable › Vulnerabilities
CVE-2024-52976: Elastic Agent Inclusion of Functionality from Untrusted Control Sphere
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-829
Description
Inclusion of functionality from an untrusted control sphere in Elastic Agent subprocess, osqueryd, allows local attackers to execute arbitrary code via parameter injection. An attacker requires local access and the ability to modify osqueryd configurations.
Affected products
- Elastic Agent: before 7.17.25; from 8.0.0 before 8.15.4 — fixed in 7.17.25, 8.15.4
How to fix
Upgrade to a fixed version: Elastic Agent 7.17.25, 8.15.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52976 or the next vulnerability affects your stack