What’s Vulnerable › Vulnerabilities
CVE-2024-52979: Elasticsearch Uncontrolled Resource Consumption vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-400
Description
Uncontrolled Resource Consumption in Elasticsearch while evaluating specifically crafted search templates with Mustache functions can lead to Denial of Service by causing the Elasticsearch node to crash.
Affected products
- Elasticsearch: before 7.17.25; from 8.0.0 before 8.16.0 — fixed in 7.17.25, 8.16.0
How to fix
Upgrade to a fixed version: Elasticsearch 7.17.25, 8.16.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52979 or the next vulnerability affects your stack