What’s Vulnerable › Vulnerabilities
CVE-2024-52981
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-08 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in Elasticsearch, where a large recursion using the Well-KnownText formatted string with nested GeometryCollection objects could cause a stackoverflow.
Affected products
- Elasticsearch: from 7.17.0 before 7.17.24; from 8.0.0 before 8.15.1 — fixed in 7.17.24, 8.15.1
How to fix
Upgrade to a fixed version: Elasticsearch 7.17.24, 8.15.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-52981 or the next vulnerability affects your stack