What’s Vulnerable › Vulnerabilities

CVE-2024-52988: Animate | Out-of-bounds Write (CWE-787)

Description

Animate versions 23.0.8, 24.0.5 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Animate 23.0.9, 24.0.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-52988 or the next vulnerability affects your stack