What’s Vulnerable › Vulnerabilities
CVE-2024-53041
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-121
Description
A vulnerability has been identified in Teamcenter Visualization V14.2 (All versions < V14.2.0.14), Teamcenter Visualization V14.3 (All versions < V14.3.0.12), Teamcenter Visualization V2312 (All versions < V2312.0008), Tecnomatix Plant Simulation V2302 (All versions < V2302.0016), Tecnomatix Plant Simulation V2404 (All versions < V2404.0005). The affected applications contain a stack based overflow vulnerability while parsing specially crafted WRL files. This could allow an attacker to execute code in the context of the current process. (ZDI-CAN-25000)
Affected products
- Siemens Teamcenter Visualization: from 14.2 before 14.2.0.14; from 14.3 before 14.3.0.12; from 2312.0 before 2312.0008 — fixed in 14.2.0.14, 14.3.0.12, 2312.0008
- Siemens Tecnomatix Plant Simulation: from 2302.0 before 2302.0016; from 2404.0 before 2404.0005 — fixed in 2302.0016, 2404.0005
How to fix
Upgrade to a fixed version: Siemens Teamcenter Visualization 14.2.0.14, 14.3.0.12, 2312.0008; Siemens Tecnomatix Plant Simulation 2302.0016, 2404.0005. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/html/ssa-583523.html
- https://cert-portal.siemens.com/productcert/html/ssa-645131.html
Get alerted when CVE-2024-53041 or the next vulnerability affects your stack