What’s Vulnerable › Vulnerabilities
CVE-2024-53070: usb: dwc3: fix fault at system suspend if device was already runtime suspended
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: usb: dwc3: fix fault at system suspend if device was already runtime suspended If the device was already runtime suspended then during system suspend we cannot access the device registers else it will crash. Also we cannot access any registers after dwc3_core_exit() on some platforms so move the dwc3_enable_susphy() call to the top.
Affected products
- Linux kernel: from 5.15.170 before 5.15.172; from 6.1.115 before 6.1.117; from 6.6.59 before 6.6.61; from 6.11.5 before 6.11.8 — fixed in 5.15.172, 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 5.15.172, 6.1.117, 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/06b98197b69e2f2af9cb1991ee0b1c876edf7b86
- https://git.kernel.org/stable/c/4abc5ee334fe4aba50461c45fdaaa4c5e5c57789
- https://git.kernel.org/stable/c/562804b1561cc248cc37746a1c96c83cab1d7209
- https://git.kernel.org/stable/c/9cfb31e4c89d200d8ab7cb1e0bb9e6e8d621ca0b
- https://git.kernel.org/stable/c/d9e65d461a9de037e7c9d584776d025cfce6d86d
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-53070 or the next vulnerability affects your stack