What’s Vulnerable › Vulnerabilities
CVE-2024-53081: media: ar0521: don't overflow when checking PLL values
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-191
Description
In the Linux kernel, the following vulnerability has been resolved: media: ar0521: don't overflow when checking PLL values The PLL checks are comparing 64 bit integers with 32 bit ones, as reported by Coverity. Depending on the values of the variables, this may underflow. Fix it ensuring that both sides of the expression are u64.
Affected products
- Linux kernel: from 6.0 before 6.1.117; from 6.2 before 6.6.61; from 6.7 before 6.11.8; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 — fixed in 6.1.117, 6.11.8, 6.6.61
How to fix
Upgrade to a fixed version: Linux kernel 6.1.117, 6.11.8, 6.6.61. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/438d3085ba5b8b5bfa5290faa594e577f6ac9aa7
- https://git.kernel.org/stable/c/5e1523076acf95b4ea68d19b6f27e6891267cc24
- https://git.kernel.org/stable/c/97ed0c0332d5525653668b31acf62ff1e6b50784
- https://git.kernel.org/stable/c/a244b82d0ae60326901f2b50c15e3118298b7ecd
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-53081 or the next vulnerability affects your stack