What’s Vulnerable › Vulnerabilities
CVE-2024-53104: Linux Kernel Out-of-Bounds Write Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-02-05
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-02 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: media: uvcvideo: Skip parsing frames of type UVC_VS_UNDEFINED in uvc_parse_format This can lead to out of bounds writes since frames of this type were not taken into account when calculating the size of the frames buffer in uvc_parse_streaming.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 2.6.26 before 4.19.324; from 4.20 before 5.4.286; from 5.5 before 5.10.230; from 5.11 before 5.15.172; from 5.16 before 6.1.117; from 6.2 before 6.6.61 — fixed in 4.19.324, 5.10.230, 5.15.172, 5.4.286, 6.1.117, 6.11.8
How to fix
Upgrade to a fixed version: Linux kernel 4.19.324, 5.10.230, 5.15.172, 5.4.286. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1ee9d9122801eb688783acd07791f2906b87cb4f
- https://git.kernel.org/stable/c/467d84dc78c9abf6b217ada22b3fdba336262e29
- https://git.kernel.org/stable/c/575a562f7a3ec2d54ff77ab6810e3fbceef2a91d
- https://git.kernel.org/stable/c/622ad10aae5f5e03b7927ea95f7f32812f692bb5
- https://git.kernel.org/stable/c/684022f81f128338fe3587ec967459669a1204ae
- https://git.kernel.org/stable/c/95edf13a48e75dc2cc5b0bc57bf90d6948a22fe8
- https://git.kernel.org/stable/c/beced2cb09b58c1243733f374c560a55382003d6
- https://git.kernel.org/stable/c/ecf2b43018da9579842c774b7f35dbe11b5c38dd
- https://git.kernel.org/stable/c/faff5bbb2762c44ec7426037b3000e77a11d6773
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-53104
Get alerted when CVE-2024-53104 or the next vulnerability affects your stack