What’s Vulnerable › Vulnerabilities
CVE-2024-53106: ima: fix buffer overrun in ima_eventdigest_init_common
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-02 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ima: fix buffer overrun in ima_eventdigest_init_common Function ima_eventdigest_init() calls ima_eventdigest_init_common() with HASH_ALGO__LAST which is then used to access the array hash_digest_size[] leading to buffer overrun. Have a conditional statement to handle this.
Affected products
- Linux kernel: from 5.19.1 before 6.1.119; from 6.2 before 6.6.63; from 6.7 before 6.11.10; 5.19, 5.19-rc7, 5.19-rc8, 6.12-rc1, 6.12-rc2, 6.12-rc3 (+4) — fixed in 6.1.119, 6.11.10, 6.6.63
How to fix
Upgrade to a fixed version: Linux kernel 6.1.119, 6.11.10, 6.6.63. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1ecf0df5205cfb0907eb7984b8671257965a5232
- https://git.kernel.org/stable/c/8a84765c62cc0469864e2faee43aae253ad16082
- https://git.kernel.org/stable/c/923168a0631bc42fffd55087b337b1b6c54dcff5
- https://git.kernel.org/stable/c/e01aae58e818503f2ffcd34c6f7dc6f90af1057e
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-53106 or the next vulnerability affects your stack