What’s Vulnerable › Vulnerabilities
CVE-2024-53110: vp_vdpa: fix id_table array not null terminated error
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-02 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: vp_vdpa: fix id_table array not null terminated error Allocate one extra virtio_device_id as null terminator, otherwise vdpa_mgmtdev_get_classes() may iterate multiple times and visit undefined memory.
Affected products
- Linux kernel: from 5.19 before 6.1.119; from 6.2 before 6.6.63; from 6.7 before 6.11.10; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 (+1) — fixed in 6.1.119, 6.11.10, 6.6.63
How to fix
Upgrade to a fixed version: Linux kernel 6.1.119, 6.11.10, 6.6.63. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0a886489d274596ad1a80789d3a773503210a615
- https://git.kernel.org/stable/c/4e39ecadf1d2a08187139619f1f314b64ba7d947
- https://git.kernel.org/stable/c/870d68fe17b5d9032049dcad98b5781a344a8657
- https://git.kernel.org/stable/c/c4d64534d4b1c47d2f1ce427497f971ad4735aae
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-53110 or the next vulnerability affects your stack