What’s Vulnerable › Vulnerabilities
CVE-2024-53137: ARM: fix cacheflush with PAN
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: ARM: fix cacheflush with PAN It seems that the cacheflush syscall got broken when PAN for LPAE was implemented. User access was not enabled around the cache maintenance instructions, causing them to fault.
Affected products
- Linux kernel: from 6.10 before 6.11.10; 6.12-rc1, 6.12-rc2, 6.12-rc3, 6.12-rc4, 6.12-rc5, 6.12-rc6 (+1) — fixed in 6.11.10
How to fix
Upgrade to a fixed version: Linux kernel 6.11.10. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/ca29cfcc4a21083d671522ad384532e28a43f033
- https://git.kernel.org/stable/c/e6960a2ed49c9a25357817535f7cc50594a58604
Get alerted when CVE-2024-53137 or the next vulnerability affects your stack