What’s Vulnerable › Vulnerabilities
CVE-2024-53145: um: Fix potential integer overflow during physmem setup
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: um: Fix potential integer overflow during physmem setup This issue happens when the real map size is greater than LONG_MAX, which can be easily triggered on UML/i386.
Affected products
- Linux kernel: from 4.1 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1575df968650d11771359e5ac78278c5b0cc19f3
- https://git.kernel.org/stable/c/1bd118c5f887802cef2d9ba0d1917258667f1cae
- https://git.kernel.org/stable/c/5c710f45811e7e2bfcf703980c306f19c7e1ecfe
- https://git.kernel.org/stable/c/a875c023155ea92b75d6323977003e64d92ae7fc
- https://git.kernel.org/stable/c/a98b7761f697e590ed5d610d87fa12be66f23419
- https://git.kernel.org/stable/c/a9c95f787b88b29165563fd97761032db77116e7
- https://git.kernel.org/stable/c/d1a211e5210d31da8f49fc0021bf7129b726468c
- https://git.kernel.org/stable/c/e6102b72edc4eb8c0858df00ba74b5ce579c8fa2
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-53145 or the next vulnerability affects your stack