What’s Vulnerable › Vulnerabilities
CVE-2024-53146: NFSD: Prevent a potential integer overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-08-04
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Prevent a potential integer overflow If the tag length is >= U32_MAX - 3 then the "length + 4" addition can result in an integer overflow. Address this by splitting the decoding into several steps so that decode_cb_compound4res() does not have to perform arithmetic on the unsafe length value.
Affected products
- Linux kernel: before 4.19.325; from 4.20 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64 — fixed in 4.19.325, 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11
How to fix
Upgrade to a fixed version: Linux kernel 4.19.325, 5.10.231, 5.15.174, 5.4.287. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/084f797dbc7e52209a4ab6dbc7f0109268754eb9
- https://git.kernel.org/stable/c/3c5f545c9a1f8a1869246f6f3ae8c17289d6a841
- https://git.kernel.org/stable/c/745f7ce5a95e783ba62fe774325829466aec2aa8
- https://git.kernel.org/stable/c/7f33b92e5b18e904a481e6e208486da43e4dc841
- https://git.kernel.org/stable/c/842f1c27a1aef5367e535f9e85c8c3b06352151a
- https://git.kernel.org/stable/c/90adbae9dd158da8331d9fdd32077bd1af04f553
- https://git.kernel.org/stable/c/ccd3394f9a7200d6b088553bf38e688620cd27af
- https://git.kernel.org/stable/c/dde654cad08fdaac370febb161ec41eb58e9d2a2
- https://git.kernel.org/stable/c/de53c5305184ca1333b87e695d329d1502d694ce
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-53146 or the next vulnerability affects your stack