What’s Vulnerable › Vulnerabilities
CVE-2024-53148: comedi: Flush partial mappings in error case
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: comedi: Flush partial mappings in error case If some remap_pfn_range() calls succeeded before one failed, we still have buffer pages mapped into the userspace page tables when we drop the buffer reference with comedi_buf_map_put(bm). The userspace mappings are only cleaned up later in the mmap error path. Fix it by explicitly flushing all mappings in our VMA on the error path. See commit 79a61cc3fc04 ("mm: avoid leaving partial pfn mappings around in error case").
Affected products
- Linux kernel: from 2.6.29 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/16c507df509113c037cdc0ba642b9ab3389bd26c
- https://git.kernel.org/stable/c/297f14fbb81895f4ccdb0ad25d196786d6461e00
- https://git.kernel.org/stable/c/57f048c2d205b85e34282a9b0b0ae177e84c2f44
- https://git.kernel.org/stable/c/8797b7712de704dc231f9e821d8eb3b9aeb3a032
- https://git.kernel.org/stable/c/9b07fb464eb69a752406e78e62ab3a60bfa7b00d
- https://git.kernel.org/stable/c/b9322408d83accc8b96322bc7356593206288c56
- https://git.kernel.org/stable/c/c6963a06ce5c61d3238751ada04ee1569663a828
- https://git.kernel.org/stable/c/ce8f9fb651fac95dd41f69afe54d935420b945bd
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-53148 or the next vulnerability affects your stack