What’s Vulnerable › Vulnerabilities
CVE-2024-53150: Linux Kernel Out-of-Bounds Read Vulnerability
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-04-09
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Fix out of bounds reads when finding clock sources The current USB-audio driver code doesn't check bLength of each descriptor at traversing for clock descriptors. That is, when a device provides a bogus descriptor with a shorter bLength, the driver might hit out-of-bounds reads. For addressing it, this patch adds sanity checks to the validator functions for the clock descriptor traversal. When the descriptor length is shorter than expected, it's skipped in the loop. For the clock source and clock multiplier descriptors, we can just check bLength against the sizeof() of each descriptor type. OTOH, the clock selector descriptor of UAC2 and UAC3 has an array of bNrInPins elements and two more fields at its tail, hence those have to be checked in addition to the sizeof() check.
Affected products
- Debian Linux: 11.0
- Linux kernel: before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/096bb5b43edf755bc4477e64004fa3a20539ec2f
- https://git.kernel.org/stable/c/45a92cbc88e4013bfed7fd2ccab3ade45f8e896b
- https://git.kernel.org/stable/c/74cb86e1006c5437b1d90084d22018da30fddc77
- https://git.kernel.org/stable/c/a3dd4d63eeb452cfb064a13862fb376ab108f6a6
- https://git.kernel.org/stable/c/a632bdcb359fd8145e86486ff8612da98e239acd
- https://git.kernel.org/stable/c/ab011f7439d9bbfd34fd3b9cef4b2d6d952c9bb9
- https://git.kernel.org/stable/c/da13ade87a12dd58829278bc816a61bea06a56a9
- https://git.kernel.org/stable/c/ea0fa76f61cf8e932d1d26e6193513230816e11d
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-53150
Get alerted when CVE-2024-53150 or the next vulnerability affects your stack