What’s Vulnerable › Vulnerabilities
CVE-2024-53153: PCI: qcom-ep: Move controller cleanups to qcom_pcie_perst_deassert()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: qcom-ep: Move controller cleanups to qcom_pcie_perst_deassert() Currently, the endpoint cleanup function dw_pcie_ep_cleanup() and EPF deinit notify function pci_epc_deinit_notify() are called during the execution of qcom_pcie_perst_assert() i.e., when the host has asserted PERST#. But quickly after this step, refclk will also be disabled by the host. All of the Qcom endpoint SoCs supported as of now depend on the refclk from the host for keeping the controller operational. Due to this limitation, any access to the hardware registers in the absence of refclk will result in a whole endpoint crash. Unfortunately, most of the controller cleanups require accessing the hardware registers (like eDMA cleanup performed in dw_pcie_ep_cleanup(), powering down MHI EPF etc...). So these cleanup functions are currently causing the crash in the endpoint SoC once host asserts PERST#. One way to address this issue is by generating the refclk in the endpoint itself and not depending on the host. But that is not always possible as some of the endpoint designs do require the endpoint to consume refclk from the host (as I was told by the Qcom engineers). Thus, fix this crash by moving the controller cleanups to the start of the qcom_pcie_perst_deassert() function. qcom_pcie_perst_deassert() is called whenever the host has deasserted PERST# and it is guaranteed that the refclk would be active at this point. So at the start of this function (after enabling resources), the controller cleanup can be performed. Once finished, rest of the code execution for PERST# deassert can continue as usual.
Affected products
- Linux kernel: from 6.10 before 6.11.11; from 6.12 before 6.12.2 — fixed in 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 6.11.11, 6.12.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/516969d5765e2302d33b4f251496eedb757d55ea
- https://git.kernel.org/stable/c/7d7cf89b119af433354f865fc01017b9f8aa411a
- https://git.kernel.org/stable/c/e03b5f1615c84f4139cb53ef8659f4cdb8d6a563
Get alerted when CVE-2024-53153 or the next vulnerability affects your stack