What’s Vulnerable › Vulnerabilities
CVE-2024-53161: EDAC/bluefield: Fix potential integer overflow
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: EDAC/bluefield: Fix potential integer overflow The 64-bit argument for the "get DIMM info" SMC call consists of mem_ctrl_idx left-shifted 16 bits and OR-ed with DIMM index. With mem_ctrl_idx defined as 32-bits wide the left-shift operation truncates the upper 16 bits of information during the calculation of the SMC argument. The mem_ctrl_idx stack variable must be defined as 64-bits wide to prevent any potential integer overflow, i.e. loss of data from upper 16 bits.
Affected products
- Linux kernel: from 5.4 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64; from 6.7 before 6.11.11 — fixed in 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 5.10.231, 5.15.174, 5.4.287, 6.1.120. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/000930193fe5eb79ce5563ee2e9ddb0c6e4e1bb5
- https://git.kernel.org/stable/c/1fe774a93b46bb029b8f6fa9d1f25affa53f06c6
- https://git.kernel.org/stable/c/4ad7033de109d0fec99086f352f58a3412e378b8
- https://git.kernel.org/stable/c/578ca89b04680145d41011e7cec8806fefbb59e7
- https://git.kernel.org/stable/c/8cc31cfa36ff37aff399b72faa2ded58110112ae
- https://git.kernel.org/stable/c/ac6ebb9edcdb7077e841862c402697c4c48a7c0a
- https://git.kernel.org/stable/c/e0269ea7a628fdeddd65b92fe29c09655dbb80b9
- https://git.kernel.org/stable/c/fdb90006184aa84c7b4e09144ed0936d4e1891a7
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-53161 or the next vulnerability affects your stack