What’s Vulnerable › Vulnerabilities

CVE-2024-5318: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.11 prior to 16.10.6, starting from 16.11 prior to 16.11.3, and starting from 17.0 prior to 17.0.1. A Guest user can view dependency lists of private projects through job artifacts.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.6, 16.11.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5318 or the next vulnerability affects your stack