What’s Vulnerable › Vulnerabilities
CVE-2024-53192: clk: clk-loongson2: Fix potential buffer overflow in flexible-array member access
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-08-04
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: clk: clk-loongson2: Fix potential buffer overflow in flexible-array member access Flexible-array member `hws` in `struct clk_hw_onecell_data` is annotated with the `counted_by()` attribute. This means that when memory is allocated for this array, the _counter_, which in this case is member `num` in the flexible structure, should be set to the maximum number of elements the flexible array can contain, or fewer. In this case, the total number of elements for the flexible array is determined by variable `clks_num` when allocating heap space via `devm_kzalloc()`, as shown below: 289 struct loongson2_clk_provider *clp; ... 296 for (p = data; p->name; p++) 297 clks_num++; 298 299 clp = devm_kzalloc(dev, struct_size(clp, clk_data.hws, clks_num), 300 GFP_KERNEL); So, `clp->clk_data.num` should be set to `clks_num` or less, and not exceed `clks_num`, as is currently the case. Otherwise, if data is written into `clp->clk_data.hws[clks_num]`, the instrumentation provided by the compiler won't detect the overflow, leading to a memory corruption bug at runtime. Fix this issue by setting `clp->clk_data.num` to `clks_num`.
Affected products
- Linux kernel: from 6.10 before 6.11.11; from 6.12 before 6.12.2 — fixed in 6.11.11, 6.12.2
How to fix
Upgrade to a fixed version: Linux kernel 6.11.11, 6.12.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02fb4f0084331ef72c28d0c70fcb15d1bea369ec
- https://git.kernel.org/stable/c/1bf8877150128c3abd9d233886a05f6966fbf0c7
- https://git.kernel.org/stable/c/b96fc194984d0c82de1ca2b4166b35b1298b216c
Get alerted when CVE-2024-53192 or the next vulnerability affects your stack