What’s Vulnerable › Vulnerabilities
CVE-2024-53217: NFSD: Prevent NULL dereference in nfsd4_process_cb_update()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-27 · updated 2026-10-15
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: NFSD: Prevent NULL dereference in nfsd4_process_cb_update() @ses is initialized to NULL. If __nfsd4_find_backchannel() finds no available backchannel session, setup_callback_client() will try to dereference @ses and segfault.
Affected products
- Linux kernel: from 2.6.38 before 4.19.325; from 4.20 before 5.4.287; from 5.5 before 5.10.231; from 5.11 before 5.15.174; from 5.16 before 6.1.120; from 6.2 before 6.6.64 — fixed in 4.19.325, 5.10.231, 5.15.174, 5.4.287, 6.1.120, 6.11.11
How to fix
Upgrade to a fixed version: Linux kernel 4.19.325, 5.10.231, 5.15.174, 5.4.287. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/03178cd8f67227015debb700123987fe96275cd1
- https://git.kernel.org/stable/c/0c3b0e326f838787d229314d4de83af9c53347e8
- https://git.kernel.org/stable/c/1e02c641c3a43c88cecc08402000418e15578d38
- https://git.kernel.org/stable/c/4a4ffc1aa9d618e41ad9151f40966e402e58a5a2
- https://git.kernel.org/stable/c/752a75811f27300fe8131b0a1efc91960f6f88e7
- https://git.kernel.org/stable/c/c5d90f9302742985a5078e42ac38de42c364c44a
- https://git.kernel.org/stable/c/cac1405e3ff6685a438e910ad719e0cf06af90ee
- https://git.kernel.org/stable/c/d9a0d1f6e15859ea7a86a327f28491e23deaaa62
- https://git.kernel.org/stable/c/eb51733ae5fc73d95bd857d5da26f9f65b202a79
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
- https://cert-portal.siemens.com/productcert/html/ssa-355557.html
Get alerted when CVE-2024-53217 or the next vulnerability affects your stack