What’s Vulnerable › Vulnerabilities

CVE-2024-53246: Sensitive Information Disclosure through SPL commands

Description

In Splunk Enterprise versions below 9.3.2, 9.2.4, and 9.1.7 and Splunk Cloud Platform versions below 9.3.2408.101, 9.2.2406.106, 9.2.2403.111, and 9.1.2312.206, an SPL command can potentially disclose sensitive information. The vulnerability requires the exploitation of another vulnerability, such as a Risky Commands Bypass, for successful exploitation.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.1.7, 9.2.4, 9.3.2; Splunk Cloud Platform 9.1.2312.206, 9.2.2403.111, 9.2.2406.106, 9.3.2408.101. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-53246 or the next vulnerability affects your stack