What’s Vulnerable › Vulnerabilities
CVE-2024-53255: Reflected Cross-site Scripting in /admin?page=media via file Parameter in BoidCMS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-25 · updated 2026-06-17
- Weakness: CWE-79
Description
BoidCMS is a free and open-source flat file CMS for building simple websites and blogs, developed using PHP and uses JSON as a database. In affected versions a reflected Cross-site Scripting (XSS) vulnerability exists in the /admin?page=media endpoint in the file parameter, allowing an attacker to inject arbitrary JavaScript code. This code could be used to steal the user's session cookie, perform phishing attacks, or deface the website. This issue has been addressed in version 2.1.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- BoidCMS: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: BoidCMS 2.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/BoidCMS/BoidCMS/commit/42f4d703a87f5199bbd701b3495a26c91b9cfab7
- https://github.com/BoidCMS/BoidCMS/security/advisories/GHSA-7q7m-cgw8-px4r
Get alerted when CVE-2024-53255 or the next vulnerability affects your stack