What’s Vulnerable › Vulnerabilities
CVE-2024-53266: Cross-site Scripting (XSS) via topic titles when CSP disabled in Discourse
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source platform for community discussion. In affected versions with some combinations of plugins, and with CSP disabled, activity streams in the user's profile page may be vulnerable to XSS. This has been patched in the latest version of Discourse core. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled.
Affected products
- discourse: before 3.3.3; before 3.4.0; 3.4.0-beta1, 3.4.0-beta2, 3.4.0-beta3 — fixed in 3.3.3, 3.4.0
How to fix
Upgrade to a fixed version: discourse 3.3.3, 3.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53266 or the next vulnerability affects your stack