What’s Vulnerable › Vulnerabilities
CVE-2024-53268: Lack of validation on openExternal allows 1 click remote code execution in joplin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-25 · updated 2026-06-17
- Weakness: CWE-94
Description
Joplin is an open source, privacy-focused note taking app with sync capabilities for Windows, macOS, Linux, Android and iOS. In affected versions attackers are able to abuse the fact that openExternal is used without any filtering of URI schemes to obtain remote code execution in Windows environments. This issue has been addressed in version 3.0.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- laurent22 joplin: before 3.0.3 — fixed in 3.0.3
How to fix
Upgrade to a fixed version: laurent22 joplin 3.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-53268 or the next vulnerability affects your stack